Ulaanbaatar
Incident Report for IPVanish
Resolved
This incident has been resolved.
Posted Dec 08, 2024 - 16:02 UTC
Investigating
We are currently investigating a potential service impacting situation in Ulaanbaatar - Virtual.
Posted Dec 08, 2024 - 14:44 UTC
This incident affected: Server Status.