Service Impacting Issue for the Athens

Incident Report for IPVanish

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 13:36 UTC

Investigating

We are currently investigating reports of a service-impacting issue for the Athens.
Posted Jun 13, 2025 - 09:56 UTC
This incident affected: Server Status.