Detroit US Maintenance Updates

Scheduled for May 15, 06:00 - 10:00 UTC

Update

Event start updated to 2026-05-15 06:00:00
Event end updated to 2026-05-15 10:00:00
Posted May 08, 2026 - 12:32 UTC

Update

Event end updated to 2026-05-14 10:00:00
Posted May 08, 2026 - 12:25 UTC

Scheduled

Detroit US Maintenance Updates
Posted May 08, 2026 - 12:25 UTC
This scheduled maintenance affects: Server Status.