Kuala Lumpur, Malaysia

Incident Report for IPVanish

Resolved

We have received no further reports of this issue.
Posted May 30, 2026 - 03:49 UTC

Investigating

Some servers may not be available while we investigate.
Posted May 29, 2026 - 23:39 UTC
This incident affected: Server Status.