LOS - Lagos Nigeria

Incident Report for IPVanish

Resolved

This incident has been resolved.
Posted Oct 31, 2025 - 11:18 UTC

Update

The issue is now fixed
Posted Oct 31, 2025 - 11:18 UTC

Investigating

We are actively investigating a potential customer impacting situation.
Posted Oct 31, 2025 - 07:04 UTC
This incident affected: Server Status.