HKG Partial Outage

Incident Report for IPVanish

Resolved

We have received no further reports of this issue.
Posted Jul 14, 2025 - 04:30 UTC

Update

We are continuing to investigate this issue.
Posted Jul 14, 2025 - 03:33 UTC

Investigating

There is a partial outage in Hong Kong, and we are currently looking into the issue.
Posted Jul 14, 2025 - 03:32 UTC
This incident affected: Server Status.