We are currently investigating a service impacting issue with Riga, Latvia

Incident Report for IPVanish

Resolved

We have received no further reports of this issue.
Posted Jul 02, 2026 - 03:56 UTC

Investigating

Some services may not be available as we investigate.
Posted Jul 01, 2026 - 22:42 UTC
This incident affected: Server Status.