Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 03, 2024 - 17:00 UTC
Scheduled
We will be performing updates to our billing platform. During this time, signups should still work but account creation may be delayed. No impact to any other systems is expected.
Posted Dec 03, 2024 - 16:59 UTC
This scheduled maintenance affected: Provisioning.