Minneapolis, United States

Incident Report for IPVanish

Resolved

This incident has been resolved.
Posted Apr 03, 2026 - 09:53 UTC

Investigating

We are investigating a potential service-impacting situation at this location.
Posted Apr 03, 2026 - 06:42 UTC
This incident affected: Server Status.