MAD - Madrid, Spain

Incident Report for IPVanish

Resolved

This incident has been resolved.
Posted Apr 29, 2025 - 06:16 UTC

Identified

We have confirmed an outage that is affecting connections to the Madrid servers.
Posted Apr 28, 2025 - 16:41 UTC
This incident affected: Support (Live Chat, Ticketing, Telephone) and Server Status, Provisioning.