SLC - Salt Lake City, USA

Incident Report for IPVanish

Resolved

This incident has been resolved. Systems are back to normal.
Posted Jun 30, 2025 - 14:15 UTC

Investigating

We are currently investigating a partial service impacting issue for some of the systems in this location.
Posted Jun 30, 2025 - 06:56 UTC
This incident affected: Server Status.