Las Vegas Maintenance Updates
Scheduled for Oct 29, 10:00 - 13:00 UTC
Update
Event start updated to 2024-10-29 10:00:00
Event end updated to 2024-10-29 13:00:00
Posted Oct 15, 2024 - 11:01 UTC
Scheduled
Las Vegas Maintenance Updates
Posted Oct 15, 2024 - 10:44 UTC
This scheduled maintenance affects: Server Status.