Kuala Lumpur Maintenance Updates

Scheduled for Jun 24, 21:00 UTC  -  Jun 25, 01:00 UTC

Update

Kuala Lumpur Maintenance Updates

Event start updated to 2025-06-24 21:00:00
Event end updated to 2025-06-25 01:00:00
Posted Jun 13, 2025 - 18:00 UTC

Scheduled

Hong Kong Maintenance Updates
Posted Jun 13, 2025 - 17:58 UTC
This scheduled maintenance affects: Server Status.