LJU - Ljubljana, Slovenia

Incident Report for IPVanish

Resolved

No further reports of this issue have been received.
Posted Mar 20, 2024 - 18:59 UTC

Investigating

We are currently investigating a potential service impacting situation in this location.
Posted Mar 19, 2024 - 20:21 UTC
This incident affected: Server Status.