Potential Service Impacting Situation for Helsinki
Incident Report for IPVanish
Resolved
This incident has been resolved.
Posted Sep 24, 2024 - 14:17 UTC
Investigating
We are currently investigating a potential service impacting situation for Helsinki. There is intermittent packet loss at this location that is affecting connections to some of the servers.
Posted Sep 24, 2024 - 09:23 UTC
This incident affected: Server Status.