Marseille France Maintenance Updates Group2

Scheduled for Aug 10, 05:05 - 07:05 UTC

Update

Event start updated to 2026-08-10 05:05:00
Event end updated to 2026-08-10 07:05:00
Posted Jul 28, 2026 - 15:03 UTC

Scheduled

Marseille France Maintenance Updates Group2
Posted Jul 28, 2026 - 14:58 UTC
This scheduled maintenance affects: Server Status.