Stockholm Sweden

Incident Report for IPVanish

Resolved

This incident has been resolved.
Posted May 15, 2026 - 15:22 UTC

Investigating

Upstream provider is performing maintenance. Some servers may not be available.
Posted May 12, 2026 - 00:25 UTC
This incident affected: Server Status.