Houston Maintenance Updates
Scheduled for Oct 28, 11:00 - 14:00 UTC
Update
Event start updated to 2024-10-28 11:00:00
Event end updated to 2024-10-28 14:00:00
Posted Oct 15, 2024 - 11:03 UTC
Update
Event start updated to 2024-10-28 12:00:00
Event end updated to 2024-10-28 15:00:00
Posted Oct 15, 2024 - 10:45 UTC
Scheduled
Houston Maintenance Updates
Posted Oct 14, 2024 - 18:53 UTC
This scheduled maintenance affects: Server Status.