Charlotte, US

Incident Report for IPVanish

Resolved

We have received no further reports of this issue.
Posted May 21, 2026 - 22:29 UTC

Investigating

We are currently investigating a potential service-impacting situation for Charlotte, US.
Some services may not be available while we investigate.
Posted May 21, 2026 - 06:32 UTC
This incident affected: Server Status.