KUL - Kuala Lumpur, Malaysia

Incident Report for IPVanish

Resolved

This incident has been resolved.
Posted Jul 10, 2026 - 15:34 UTC

Investigating

We are currently investigating a potential service impacting situation in this location.
Posted Jul 10, 2026 - 14:25 UTC
This incident affected: Server Status.