Bucharest, Romania

Incident Report for IPVanish

Resolved

This incident has been resolved.
Posted Jan 11, 2026 - 08:48 UTC

Investigating

There is an intermittent service impacting issue at this location, which is being investigated.
Posted Jan 11, 2026 - 01:16 UTC
This incident affected: Server Status.