LON - London, UK

Incident Report for IPVanish

Resolved

All systems in London are operational.
Posted Oct 27, 2025 - 06:42 UTC

Investigating

We are currently investigating a potential service impacting situation in this location.
Posted Oct 26, 2025 - 19:50 UTC
This incident affected: Server Status.