Montreal Canada Maintenance Updates Part 2

Scheduled for Jun 8, 07:05 - 09:30 UTC

Update

Montreal Canada Maintenance Updates Part 2
Posted May 25, 2026 - 14:34 UTC

Update

Event end updated to 2026-06-08 09:30:00
Posted May 25, 2026 - 14:31 UTC

Update

Event end updated to 2026-06-08 10:30:00
Posted May 25, 2026 - 14:30 UTC

Update

Event end updated to 2026-06-08 10:00:00
Posted May 25, 2026 - 14:17 UTC

Scheduled

Montreal Canada USA Maintenance Updates Part 2
Posted May 25, 2026 - 14:14 UTC
This scheduled maintenance affects: Server Status.