Service impacting issue with Jeddah, Ulaanbaatar and Thimphu

Incident Report for IPVanish

Resolved

This incident has been resolved.
Posted Mar 07, 2025 - 10:09 UTC

Investigating

There is a service impacting issue with Jeddah, Ulaanbaatar and Thimphu. We are currently looking into the issue
Posted Mar 07, 2025 - 03:35 UTC
This incident affected: Server Status.