Bucharest City, Romania

Incident Report for IPVanish

Resolved

This incident has been resolved.
Posted Aug 31, 2026 - 13:17 UTC

Investigating

We are currently investigating a potential service-impacting situation. Some servers may not be available at this time.
Posted Aug 31, 2026 - 12:00 UTC
This incident affected: Server Status.