Buffalo, New York

Incident Report for IPVanish

Resolved

We have received no further reports of this issue.
Posted Aug 27, 2025 - 17:20 UTC

Update

We are continuing to work on a fix for this issue.
Posted Aug 27, 2025 - 13:33 UTC

Identified

We are currently performing unscheduled maintenance. Servers will be unavailable. We apologize for the inconvenience.
Posted Aug 27, 2025 - 13:33 UTC
This incident affected: Server Status.