Potential service impacting situation for Helsinki, Finland

Incident Report for IPVanish

Resolved

This incident has been resolved.
Posted 4 days ago. Apr 01, 2025 - 07:12 UTC

Investigating

We are currently investigating a potential service impacting situation for Helsinki, Finland. There is partial outage at this location that is affecting connections to some of the servers.
Posted 4 days ago. Apr 01, 2025 - 05:05 UTC
This incident affected: Server Status.