CVG, DTW, STL - Cincinnati, Detroit and St. Louis, USA

Incident Report for IPVanish

Resolved

This incident has been resolved
Posted Apr 19, 2025 - 22:00 UTC

Investigating

We are currently investigating a service impacting situation that is affecting connections to the servers at these locations.
Posted Apr 19, 2025 - 06:48 UTC
This incident affected: Server Status.