Phoenix USA Maintenance Updates Part 1

Scheduled for Jun 3, 08:00 - 12:00 UTC

Update

Event end updated to 2026-06-03 12:00:00
Posted May 25, 2026 - 14:29 UTC

Scheduled

Phoenix USA Maintenance Updates Part 1
Posted May 25, 2026 - 12:58 UTC
This scheduled maintenance affects: Server Status.