Service Impacting Situation for Islamabad Pakistan

Incident Report for IPVanish

Resolved

We have received no further reports of this issue.
Posted Jun 18, 2025 - 13:20 UTC

Investigating

We are currently investigating reports of a service-impacting issue for Islamabad, Pakistan. We are currently investigating the issue.
Posted Jun 18, 2025 - 10:11 UTC
This incident affected: Server Status.