GYD Baku/EVN and TBS locations Connectivity Issue

Incident Report for IPVanish

Resolved

No further reports of this issue have been received.
Posted Jul 21, 2025 - 04:00 UTC

Investigating

We are currently looking into the issue and at the moment VPN connections with these locations will not be possible.
Posted Jul 21, 2025 - 00:31 UTC
This incident affected: Server Status.