Guatemala City - Guatemala
Incident Report for IPVanish
Resolved
This incident has been resolved.
Posted Dec 13, 2024 - 18:04 UTC
Investigating
There is a hardware issue with the location. We do not have an expected time on when the severs will be back online, but will update the status as soon as we get new information.
Posted Dec 13, 2024 - 10:05 UTC
This incident affected: Server Status.