KUL service disruption
Incident Report for IPVanish
Resolved
The network connections with KUL have returned to normal over the last few hours.
Posted Apr 23, 2024 - 09:47 UTC
Investigating
We are currently investigating a potential service impacting situation at this location. There is packet loss at this location to the international links.
Posted Apr 23, 2024 - 04:09 UTC
This incident affected: Server Status.